Задать вопрос
30 сентября, 22:52

Напишите программу, вычисляющую и выводящкю 10 первых членов последовательности Фибоначчи

+3
Ответы (1)
  1. 1 октября, 02:15
    0
    Var f1, f2, f, i:integer;

    begin

    f1:=1; f2:=1;

    write (f1,' ', f2,' ') ;

    for i:=3 to 10 do

    begin

    f:=f1+f2;

    write (f,' ') ;

    f1:=f2;

    f2:=f;

    end;

    writeln;

    end.

    Результат:

    1 1 2 3 5 8 13 21 34 55
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, вычисляющую и выводящкю 10 первых членов последовательности Фибоначчи ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачу на Паскале. Числа Фибоначчи определяются как а (0) = 1, а (1) = 1, а (i) = a (i-1) + a (i-2). Найти десятое число Фибоначчи. Найти : a) N-ое число Фибоначчи б) Сумму первых N чисел Фибоначчи
Ответы (1)
Дата рождения. Профессор Бит Байтович Алгоритмович черезвычайно гордится своим гениальным, по его мнению сыном.
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)