Задать вопрос
6 мая, 09:19

Составьте программу, которая позволяет заменить в строке слово мама на слово папа

+5
Ответы (1)
  1. 6 мая, 12:11
    0
    Var / / Объявляем переменные

    i:integer;

    s:string;

    begin / / Начало работы блока

    readln (s) ; / / В переменную S записываем введенную строку

    i : = Pos ('мама', s) ; / / В переменную i записываем количество символов до данного слова

    if i > 0 then / / Если количество символов больше нуля тогда

    begin

    Delete (s, i, 4) ; / / Удаляем из веденной строки (Переменная S), слово мама, содержащие 4 символа

    Insert ('папа', s, i) ; / / Заменяем словом Папа

    end; / / Конец

    writeln (s) ; / / Выводим на экран полученный текст

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая позволяет заменить в строке слово мама на слово папа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль Составьте программу, которая заменяет в строке S слово "мама" на слово "папа" Пример ввода: Мама играет с ребенком. Пример вывода: Папа играет с ребенком.
Ответы (1)
задача 1 Cоставить программу, которая позволяет ввести строку s, затем после каждой буквы "а" вставить пробел. задача 2 Составить программу, которая удаляет в строке S все буквы "о"
Ответы (1)
Размер окна текстового редактора - 20 строк по 64 символа в строке. Курсор находится в левом верхнем углу экрана и указывает на символ, стоящий в 25 - й строке и 5 - й позиции текста.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)