Задать вопрос
24 мая, 06:45

Составить программу в паскале ABC для решения следующей задачи. С клавиатуры вводятся 3 произвольных числа. Если второе число больше суммы первого и третьего, то вывести сумму этих двух чисел. Если первое число положительное, то вывести среднее арифметическое трех чисел.

+4
Ответы (1)
  1. 24 мая, 10:13
    0
    Program qq;

    uses CRT;

    var x1, x2, x3, sum2, SrArVsChi:integer;

    begin

    write ('Первое число равно ') ;

    readln (x1) ;

    write ('Второе число равно ') ;

    readln (x2) ;

    write ('Третье число равно ') ;

    readln (x3) ;

    if x2 > (x1+x3) then

    sum2:=x1+x3;

    writeln (sum2) ;

    if x1 > = 0 then

    SrArVsChi: = (x1+x2+x3) / 3;

    writeln (SrArVsChi) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в паскале ABC для решения следующей задачи. С клавиатуры вводятся 3 произвольных числа. Если второе число больше суммы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (2)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)