Задать вопрос
3 сентября, 02:51

В каждом шкафу 9 полок, на каждой полке по 4 книги. Напишите программу, определяющую, в каком по номеру шкафу и на какой полке находится n-я книга. паскаль

+4
Ответы (1)
  1. 3 сентября, 03:06
    0
    Если шкафы и полки нумеровать с 1, то можно так:

    var n, a, b:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    a: = (n-1) div (9*4) + 1;

    b: = (n - (a-1) * 9*4-1) div 4+1;

    writeln ('Шкаф = ', a,' полка = ', b) ;

    end.

    Пример:

    n = 57

    Шкаф = 2 полка = 6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В каждом шкафу 9 полок, на каждой полке по 4 книги. Напишите программу, определяющую, в каком по номеру шкафу и на какой полке находится ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Напишите программу, определяющую сумму S=1+2+3+4 ... + 99 2. Напишите программу, определяющую произведение P=1*2*3*4 ... * 10 На Паскаль За ранее благодарна
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите программу определяющую каких элементов в точке больше положительных или отрицательных
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)