Задать вопрос
14 июля, 13:39

1) Вычислить сумму четных и нечетных элементов (также в массиве).

2) Вычислить количество "0" в массиве.

Написать программу в Pascal.

P. S.: можно сделать одну задачу из двух.

+5
Ответы (1)
  1. 14 июля, 14:49
    0
    Program sum_nechet;

    var a: array [0 ... 100] of integer;

    var b, i, c, k:integer;

    begin

    randomize;

    for i:=1 to 10 do

    begin

    a[i]:=random (10) ;

    writeln (a[i]) ; / / Это можно не писать, просто чтобы видеть числа в массиве, если интересно.

    end;

    c : = 0;

    b : = 0;

    for i:=1 to 10 do

    begin

    if a[i] mod 2 = 0 then

    b : = b + a[i]

    else

    c : = c + a[i];

    end;

    writeln ('Нечетных ', c) ;

    writeln ('Четных ', b) ;

    k:=0;

    for i:=1 to 10 do

    begin

    if a[i] = 0 then

    k: = k+1

    end;

    writeln ('Нулей ', k)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Вычислить сумму четных и нечетных элементов (также в массиве). 2) Вычислить количество "0" в массиве. Написать программу в Pascal. P. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В одномерном массиве, состоящем из n элементов, вычислить: 1) количество отрицательных элементов массива, расположенных на четных местах 2) сумму четных элементов массива, расположенных на нечетных местах.
Ответы (1)
Имеется целочисленный массив состоящий из N элементов (N - чётное) а) Найти сумму первых N/2 элементов. б) Найти сумму элементов стоящих на чётных позициях. в) Найти произведение элементов стоящих на нечётных позициях.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Задача Pascal Найти наименьшие элементы в каждом столбце матрицы Х (5,5) и переписать их в одномерных массив А. В массиве А вычислить сумму элементов, стоящих на четных местах и произведение элементов, стоящих на нечетных местах.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)