Задать вопрос
11 января, 07:51

Переменная Х содержит трехзначное целое число. подсчитать сумму цифр этого числа

+5
Ответы (1)
  1. 11 января, 10:42
    0
    Program abc;

    var x, a, b, c: integer;

    begin

    writeln ('vvedite chislo') ;

    readln (x) ;

    a:=x div 100;

    b:=x mod 100 div 10;

    c:=x mod 10;

    writeln (a+b+c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Переменная Х содержит трехзначное целое число. подсчитать сумму цифр этого числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Робот собирает помидоры в теплице, исполняя алгоритм. он должен собрать плоды с семи растений и подсчитать, сколько помидоров собрал. заполни пропуски в алгоритме. переменная Н содержит количество собранных плодов, а переменная к номер куста.
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)