Задать вопрос
11 августа, 02:52

Составить программу выводящую на экран все делители на число х. (число х вводится с клавиатуры)

+3
Ответы (1)
  1. 11 августа, 03:25
    0
    program ml;

    uses crt;

    var x, i:integer;

    w, l:real;

    begin

    clrscr;

    readln (x) ;

    L:=x;

    for i:=1 to x do begin

    w:=w+1;

    l:=x/w;

    if frac (l) = 0 then writeln (l:2:0) ;

    end;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу выводящую на экран все делители на число х. (число х вводится с клавиатуры) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
составить программу выводящую на экран все делители числа x, число x, введите с клавиатуры
Ответы (1)
Дано натуральное число N (Вводится с клавиатуры). Написать программу, выводящую на экран натуральные числа от 1 до N. входные данные 4 выходные данные 1 2 3 4
Ответы (1)