Задать вопрос
16 августа, 22:16

Найти максимальный и минимальный элементы и поменять их местами. помогите

+1
Ответы (1)
  1. 16 августа, 22:42
    0
    uses crt;

    const max=100;

    var a:array[1 ... max] of integer;

    n, i, imn, imx:byte;

    x:integer;

    begin

    clrscr;

    randomize;

    repeat

    write ('Размер массива n: ') ;

    readln (n) ;

    until n in [1 ... max];

    writeln ('Исходный массив: ') ;

    for i:=1 to n do

    begin

    a[i]:=random (20) + 1;

    write (a[i],' ') ;

    end;

    imn:=1;

    imx:=1;

    for i:=1 to n do

    begin

    if a[i]
    if a[i]>a[imx] then imx:=i;

    end;

    writeln ('Минимальный элемент: ', a[imn],' Его индекс: ', imn) ;

    writeln ('Максимальный элемент: ', a[imx],' Его индекс: ', imx) ;

    x:=a[imn];

    a[imn]:=a[imx]; a[imx]:=x;

    writeln ('Обмне максимального и минимального: ') ;

    for i:=1 to n do

    write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти максимальный и минимальный элементы и поменять их местами. помогите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в pascal'e. Если матрица квадратная, то поменять местами минимальный и максимальный элементы побочной диагонали. В противном случае-заменить элементы четных строк нулями.
Ответы (1)
В одномерном массиве поменять местами минимальный и максимальный элементы. Все элементы большие 4 заменить числом 4. Посчитать количество таких элементов.
Ответы (1)
Паскаль! Заполните массив случайными числами и найти минимальный и максимальный элементы массива и их номера. Пример: Массив: 1 2 3 4 5 Минимальный элемент: A[1]=1 Максимальный элемент: A[5]=5
Ответы (1)
Заполнить массив случайными числами и найти минимальный и максимальный элементы массива и их номера Пример: Массив: 1 2 3 4 5 Максимальный элемент: А[1]=1 Минимальный элемент: А[5]=5 10 класс
Ответы (1)
Задать массив размерности 25 случайным образом от - 10 до 9. Поменять местами первый минимальный и последний максимальный элементы массива. Вывести первоначальный массив и получившийся массив. Помогите решить в паскале
Ответы (1)