Задать вопрос
6 декабря, 08:00

Тема

Дано N чисел. Найдите сумму чисел, больших заданного числа А

+1
Ответы (1)
  1. 6 декабря, 11:01
    0
    Program n1;

    Uses CRT;

    Const n=10;

    Var x:array[1 ... n] of integer;

    i, s, a: integer;

    begin

    Writeln ('Vvedite chisla') ;

    For i:=1 to n do

    readln (x[i]) ;

    Writeln ('Vvedite A') ;

    Readln (a) ;

    For i:=1 to n do

    if x[i]>a then s:=s+x[i];

    Writeln ('Summa elementov, bolshih a = ', s) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Тема Дано N чисел. Найдите сумму чисел, больших заданного числа А ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
1. С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел. (Тема: Программирование ветвлящихся и цепленных алгоритмов) 2. Дано двухзначное число, найти сумму и произведение его чисел.
Ответы (1)