Задать вопрос
28 ноября, 21:55

генератором случайных чисел (от 0 до 100) задан массив из 20 целых чисел. составьте программу, с помощью которой напечатайте на одной строчке исходный массив, а на следующей строке - сумму квадратов элементов с начетными индексами

+3
Ответы (1)
  1. 29 ноября, 00:43
    0
    uses crt;

    var i, s:integer;

    a:array[1 ... 20] of integer;

    begin

    for i:=1 to 20 do a[i]:=random (100) + 0;

    for i:=1 to 20 do write (a[i],' ') ;

    writeln;

    for i:=1 to 20 do if i mod 2 0 then s:=s+sqr (a[i]) ;

    writeln ('suma = ', s) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «генератором случайных чисел (от 0 до 100) задан массив из 20 целых чисел. составьте программу, с помощью которой напечатайте на одной ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
1) Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2) Задан массив из 11 целых чисел. Посчитать количество нечётных элементов массива. 3) задан массив из 9 целых чисел. Вывести на экран чётные элементы
Ответы (1)