Задать вопрос
27 мая, 01:11

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу. (pascal)

+1
Ответы (1)
  1. 27 мая, 02:06
    0
    uses crt;

    var i, s, a, b, c, ch, o:integer;

    begin

    o:=0;

    writeln (' Vvedite chislo ') ;

    readln (ch) ;

    for i:=100 to 999 do

    begin

    a:=i div 100;

    b: = (i div 10) mod 10;

    c:=i mod 10;

    if ((a+b+c) = ch) then

    begin

    inc (o) ;

    writeln (i) ;

    end;

    end;

    if o = 0 then writeln ('error!') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите все трехзначные числа, сумма цифр которых равна данному целому числу. (pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) вывести трехзначные числа сумма цифр которых простое число pascal. 2) Дана последовательность 5,9,13,17, ... Составте программу для определения числа слагаемых, сумма которых равна 324.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Составить программу в Pascal: Найти все трехзначные числа, обладающие следующими свойствами: - сумма цифр числа А делится на 4; - сумма цифр числа А+2 также делится на 4
Ответы (1)