Задать вопрос
19 декабря, 21:14

Сколько существуют двузначных чисел сумма цифр которых = 7. Запишите на языке программирования

+3
Ответы (2)
  1. 20 декабря, 00:22
    0
    var n, i, i1, i2:integer;

    Begin

    for i: = 10 to 99 do Begin

    i1:=i div 10;

    i2:=i mod 10;

    if (i1+i2=7) then n:=n+1;

    end;

    writeln (n) ;

    End.
  2. 20 декабря, 01:07
    0
    Издеваться изволите? Сварите вашего учителя заживо (это не призыв к насилию, а едкое замечание!), если он предлагает такие задачи.

    Pascal:

    var i, n: integer;

    begin

    n:=0;

    for i:=10 to 99 do

    if ((i mod 10) + (i div 10) = 7) then inc (n) ;

    writeln ('Otvet: ', n, 'number (s) ') ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сколько существуют двузначных чисел сумма цифр которых = 7. Запишите на языке программирования ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
запишите на языке программирования запишите на языке программирования сложное условие сложное условие
Ответы (1)
Для чего предназначены системные программирования? Для разработки каких типов программного обеспечения служат системы программирования? Кто может работать с системой программирования?
Ответы (1)
Автомат получает на вход два двузначных десятичных числа. По полученным числам строится новое десятичное число по следующим правилам. 1. Вычисляются два числа - сумма цифр первого числа и сумма цифр второго числа. 2.
Ответы (1)
Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не
Ответы (1)