Задать вопрос
31 мая, 10:05

удалить из массива все отрицательные элементы и вставить сумму оставшихся элементов (программа в Паскале)

+4
Ответы (1)
  1. 31 мая, 11:17
    0
    var a:array[1 ... 100] of integer;

    i, s:integer;

    Begin

    randomize;

    n:=20;

    for i: = 1 to n do begin

    a[i]:=random (n*10) - 10*n div 2;

    write (a[i]:4) ;

    if i mod 10=0 then writeln;

    if a[i]>=0 then s: = s+a[i];

    end;

    for i: = 1 to n do begin

    if a[i]<0 then a[i]:=s;

    write (a[i]:4) ;

    if i mod 10=0 then writeln;

    end;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «удалить из массива все отрицательные элементы и вставить сумму оставшихся элементов (программа в Паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)