Задать вопрос
16 мая, 19:21

вычислить сумму Z = 1 + 2 + 3 + ... Вычисления прекратить, когда значение Z превысит заданное значение A.

+2
Ответы (1)
  1. 16 мая, 21:03
    0
    var a, z, n: integer;

    begin

    n:=1;

    z:=0;

    readln (a) ;

    repeat

    z:=z+n;

    n:=n+1

    until z>a;

    writeln (z) ;

    end.

    Вот программа
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «вычислить сумму Z = 1 + 2 + 3 + ... Вычисления прекратить, когда значение Z превысит заданное значение A. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
водится положительное число прекратить ввод когда сумма введёных чисел превысит 100
Ответы (1)
Задача о тренировках план тренировок пробежать 10 км. Каждый следующий день увеличивать расстояние на 10% от результата предыдущего дня. Как только дневной пробег достигнет или превысит 25 км. прекратить увеличение и пробегать 25 км. ежедневно.
Ответы (1)
Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Определить: за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Вычислить частичную сумму ряда S=1/2^2+1/3^2+1/4^2 + ... Вычисление прекратить, когда модуль очередного слагаемого станет меньше 0,001. Проверьте, насколько сумма приблизилась к значению pi^2/6.
Ответы (1)