Задать вопрос
10 января, 17:44

Составить программу вставки в массив A (N) первого элемента, равного 7

+3
Ответы (2)
  1. 10 января, 20:02
    0
    Program R1;

    Var a:array[1 ... 100] of integer;

    i, n:integer;

    begin

    assign (input,'input. txt') ;

    reset (input) ;

    assign (output,'output. txt') ;

    rewrite (output) ;

    readln (n) ;

    for i:=1 to n do read (a[i]) ;

    for i:=n+1 downto 2 do

    a[i]:=a[i-1];

    a[1]:=7;

    for i:=1 to n+1 do write (a[i],' ') ;

    close (input) ;

    close (output) ;

    end.

    например

    ввод

    4

    1 2 3 4

    вывод

    7 1 2 3 4
  2. 10 января, 20:47
    0
    var a:array [1 ... 100] of integer;

    i, n:integer;

    Begin

    read (n) ;

    for i: = 1 to n do

    read (a[i]) ;

    for i: = n downto 1 do

    a[i+1]:=a[i];

    a[1]:=7;

    for i:=1 to n+1 do

    write (a[i],' ') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вставки в массив A (N) первого элемента, равного 7 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программы с процедурой вставки В строку s1 занесите свои фамилию и отчество (через пробел). В строку s2 занесите свое имя. С помощью процедуры вставки измените строку s1 таким образом, чтобы она содержала Ваши фамилию, имя, отчество.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Задание 1. Заполнение массива от a до b Дан массив из 30 элементов. Заполнить массив начиная с элемента a до элемента b двойками, а остальные элементы нулями и вывести весь массив на экран.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)