Задать вопрос
7 апреля, 23:11

Задание 1. Заполнение массива от a до b

Дан массив из 30 элементов. Заполнить массив начиная с элемента a до элемента b двойками, а остальные элементы нулями и вывести весь массив на экран.

Известно, что 1<=a

Формат ввода

Вводятся 2 целых числа 1<=a

Формат вывода

Массив из 30 элементов

Пример

Ввод

2 10

Вывод

0 2 2 2 2 2 2 2 2 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

в Паскале ABC (не обновленном)

+2
Ответы (1)
  1. 8 апреля, 00:09
    0
    Var M:array[1 ... 30] of integer;

    i, a, b:integer;

    Begin

    Read (a, b) ;

    For i: = 1 to a-1 do

    M[i]:=0;

    For b: = a to b do

    M[b]:=2;

    For i: = b+1 to 30 do

    M[i]:=0;

    For i: = 1 to 30 do

    Write (M[i],' ')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задание 1. Заполнение массива от a до b Дан массив из 30 элементов. Заполнить массив начиная с элемента a до элемента b двойками, а ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)