Задать вопрос
26 июня, 10:01

Написать программу, Паскаль. Дано натуральное число N. Вычислить S = 1! + 2! + 3! + ... + n! (n>=1) Решить через repeat (с постусловием)

+1
Ответы (1)
  1. 26 июня, 13:34
    0
    Var S, f:longint; n, a:byte;

    begin

    s:=0; a:=1; f:=1;

    readln (n) ;

    repeat

    f:=f*a;

    s:=s+f;

    inc (a) ;

    until a>n;

    writeln (s) ;

    end.

    Вроде так
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, Паскаль. Дано натуральное число N. Вычислить S = 1! + 2! + 3! + ... + n! (n>=1) Решить через repeat (с постусловием) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы