Задать вопрос
30 ноября, 02:24

1. Пешеход шел по пересеченной местности. Его скорость движения по равнине v1 км/ч, в гору - v2 км/ч и под гору - v3 км/ч. Время движения соответственно t1, t2 и t3 ч. Написать программу определяющую, какой путь прошел пешеход? 2. Написать программу, вычисляющую путь, пройденный лодкой, если ее скорость в стоячей воде v км/ч, скорость течения реки v1 км/ч, время движения по озеру t1 ч, а против течения реки - t2 ч.

+5
Ответы (1)
  1. 30 ноября, 06:20
    0
    Program Program1;

    var

    s, v1, v2, v3, t1, t2, t3:real;

    begin

    write ('Введите скорость движения по равнине: ') ;

    readln (v1) ;

    write ('Введите скорость движения в гору: ') ;

    readln (v2) ;

    write ('Введите скорость движения под гору: ') ;

    readln (v3) ;

    write ('Введите время движения по равнине: ') ;

    readln (t1) ;

    write ('Введите время движения в гору: ') ;

    readln (t2) ;

    write ('Введите время движения под гору: ') ;

    readln (t3) ;

    S:=t1*v1+t2*v2+t3*v3;

    writeln ('Путь = ', S) ;

    end.

    Program Program2;

    var

    s, v, v1, t1, t2:real;

    begin

    write ('Введите скорость лодки в стоячей воде: ') ;

    readln (v) ;

    write ('Введите скорость течения реки: ') ;

    readln (v1) ;

    write ('Введите время движения по озеру: ') ;

    readln (t1) ;

    write ('Введите время движения против течения реки: ') ;

    readln (t2) ;

    S:=t1*v+t2 * (v-v1) ;

    writeln ('Путь = ', S) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Пешеход шел по пересеченной местности. Его скорость движения по равнине v1 км/ч, в гору - v2 км/ч и под гору - v3 км/ч. Время движения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить путь, пройденный лодкой, если ее скорость в стоячей воде v км/ч, скорость течения реки v1 км/ч, время движения по озеру t1 ч, а против течения реки - t2 ч. Составьте блок-схему и записать алгоритм решения поставленной задачи.
Ответы (1)
Скорость лодки в стоячей воде V км/ч, скорость течения реки U км/ч (U < V). Время движения лодки по озеру T1 ч, а по реке (против течения) - T2 ч. Определить путь S, пройденный лодкой
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)