Задать вопрос
23 июля, 18:29

найти сколько элементов одномерного массива А встречаются в одномерном массиве В паскаль

+2
Ответы (1)
  1. 23 июля, 20:16
    0
    var a, b:array [1 ... 100] of integer;

    an, bn, i, j, n:integer;

    Begin

    read (an, bn) ;

    for i: = 1 to an do

    read (a[i]) ;

    for i: = 1 to bn do

    read (b[i]) ;

    for i: = 1 to an do

    for j: = 1 to bn do

    if a[i]=b[j] then n:=n+1;

    writeln (n) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «найти сколько элементов одномерного массива А встречаются в одномерном массиве В паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)