Задать вопрос
28 мая, 21:49

упорядочить по возрастанию массив целых чисел a1 ... an используя алгоритм сортировки выбором

+4
Ответы (1)
  1. 29 мая, 00:32
    0
    const

    N = 15;

    var

    a: array[1 ... N] of integer;

    i, j, tmp: integer;

    begin

    for i : = 1 to N do begin

    a[i] : = random (50) ;

    write (a[i], ' ') ;

    end;

    writeln;

    for i : = 1 to N - 1 do

    for j : = 1 to N - i do

    if a[j] > a[j+1] then begin

    tmp : = a[j];

    a[j] : = a[j+1];

    a[j+1] : = tmp

    end;

    write ('По возрастанию: ') ;

    for i : = 1 to N do

    write (a[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «упорядочить по возрастанию массив целых чисел a1 ... an используя алгоритм сортировки выбором ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Напишите программу, которая сортирует массив и находит количество различных чисел в нем. Используйте алгоритм быстрой сортировки. Пример: Массив: 5 3 4 2 1 6 3 2 4 После сортировки: 1 2 2 3 3 4 4 5 6 Различных чисел: 5
Ответы (1)
Помогите вопросы по информатике. 1. Какой вид сортировки используют для сортировки по нескольким параметрам? 2. Назначение сортировки 3. Какие типы данных можно сортировать.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Для сортировки N чисел по возрастанию пузырьковым методом применяют следующий алгоритм: сначала сравнивают первые два числа, если первое число больше второго, то их меняют местами, потом сравнивают вторую и третью и т. д ...
Ответы (1)