Задать вопрос
8 февраля, 02:45

измените программу так, чтобы она вычисляла: а) дробную часть чисел, б) произведение чисел меньших 22, в) сумму чисел которые попадают в промежуток от 10 до 50 (включительно оба). P. S. в паскале и в одной программе

+3
Ответы (1)
  1. 8 февраля, 06:10
    0
    var

    m:char;

    a, b, j, k:integer;

    c:real;

    begin

    readln (m) ;

    if m='a' then

    begin

    readln (a) ;

    readln (b) ;

    c: = a/b - a div b;

    writeln (c:4:2) ;

    end;

    if m='b' then

    begin

    j:=1;

    k:=1;

    while k < 22 do

    begin

    j : = j*k;

    k: = k+1;

    end;

    writeln (j) ;

    end;

    if m='c' then

    begin

    j:=0;

    k:=10;

    while k < = 50 do

    begin

    j : = j+k;

    k: = k+1;

    end;

    writeln (j) ;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «измените программу так, чтобы она вычисляла: а) дробную часть чисел, б) произведение чисел меньших 22, в) сумму чисел которые попадают в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Пусть элементами круга являются радиус (первый элемент), диаметр (второй элемент) и длина окружности (третий элемент). Составить программу, которая по номеру элемента запрашивала бы его соответствующее значение и вычисляла бы площадь круга.
Ответы (1)
Написать программу Паскаль, которая б вычисляла сумму процентов начисленных в банке под 18% на срок - 1 год. Входные данные: сумма. Выходные данные: сумма процентов.
Ответы (1)