Задать вопрос
28 ноября, 05:38

В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешевого товара и его индекс.

+2
Ответы (1)
  1. 28 ноября, 09:03
    0
    Массив данных о стоимости товаров зададим в виде целочисленных констант

    program primer_1;

    const a: array[1 ... 12] of integer = (170, 180, 25, 36, 750, 1, 45, 28, 39, 10, 11, 58) ;

    i, min, k: integer;

    begin

    min:=a[1];

    for i:=2 to 12 do if a[i]
    begin

    min:=a[i];

    k:=i;

    write ('минимальная стоимость ', min, ' индекс', k)

    end.

    Или скорее всего этот вариант

    program primer_1;

    var a: array[1 ... 12] of integer;

    i, min, k: integer;

    begin

    for i:=1 to 12 do read (a[i]) ; {Ввод стоимостей товаров}

    min:=a[1];

    k:=0;

    for i:=2 to 12 do

    if a[i]
    then

    begin

    min:=a[i];

    k:=i;

    end;

    write ('мин. сто-мость ', min, ' индекс ', k)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешевого товара и его индекс. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)
Вычислить сумму и разность двух одномерных массивов содержащих 20 элементов. В массиве суммы найти максимальный элемент и его индекс. В массиве разности найти минимальный элемент и его индекс. Исходные массивы ввести при помощи случайных чисел.
Ответы (1)
Какая информация называется достоверной? Выберите один ответ: Информация, которую можно представить графически Информация, которой удобно пользоваться Информация с минимумом фактов Информация, адекватно описывающая предметную область Информация,
Ответы (2)
Какая информация называется субъективной? Выберите один ответ: Информация, которая передаётся от одного субъекта другому Информация на дискете отдельного пользователя Информация, отражающая точку зрения отдельного пользователя Информация в бумажной
Ответы (2)
1. Написать программу, которая определяет наибольшее отрицательное целое число в массиве из 10 элементов. Значения элементов массива вводятся пользователем. 2.
Ответы (1)