Задать вопрос
22 мая, 20:23

составьте блок схему алгоритма и программу расположения трех чисел в порядке убывания

+5
Ответы (1)
  1. 22 мая, 21:53
    0
    1) на Pascal:

    var

    t, i, j:integer;

    a:array[1 ... 4]of integer;

    begin

    for i:=1 to 4 do

    begin

    write ('Vvedite ', i,'-i 4islo: ') ;

    readln (a) ;

    end;

    for i:=2 to 4 do

    for j:=4 downto i do

    if a[j-1]>a[j] then

    begin

    t:=a[j-1];

    a[j-1]:=a[j];

    a[j]:=t;

    end;

    writeln ('Raspolagaem 4isla v poryadke vozrastaniya:') ;

    for i:=1 to 4 do

    writeln (a) ;

    readln;

    end.

    2) на С:

    #include

    #include

    void main (void) {

    int n, a, b, c, d;

    printf ("/nVvedite 4x-znachnoe chislo n: ") ;

    scanf ("%i", &n) ;

    a=n/1000;

    b = (n-a*1000) / 100;

    c = (n-a*1000-b*100) / 10;

    d=n-a*1000-b*100-c*10;

    if (a+b==c+d) printf ("true") ;

    else printf ("false") ;

    getch () ;

    };
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составьте блок схему алгоритма и программу расположения трех чисел в порядке убывания ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
Что такое алгоритм? Что такое исполнитель? Что такое среда исполнителя? Что называется командой? Что такое формальный исполнитель? Что такое неформальный исполнитель? Назовите режимы работы исполнителя Что такое система команд исполнителя?
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Одномерный массив 1. Составьте программу ввода и вывода массива: 5, - 2, 3, - 6, 7, 9, - 4, 8, 1, 2, 7, - 3. 2. Составьте блок-схему алгоритма и программу вычисления в массиве A (10) количества положительных элементов. 3.
Ответы (1)
Формальное исполнение алгоритма - это? Выберите один ответ: A. Разбиение алгоритма на конкретное число команд и их пошаговое исполнение B. Исполнение алгоритма конкретным исполненителем с полной записью его рассуждений C.
Ответы (1)