Задать вопрос
24 апреля, 04:08

Дано двузначное число. выяснить является ли оно палиндромом то есть таким числом десятичная запись которого читается слева направо и справа налево

+5
Ответы (1)
  1. 24 апреля, 07:31
    0
    Var n:longint;

    begin

    repeat

    write ('N = ') ;

    readln (n) ;

    until n in [10 ... 99];

    if n = ((n mod 10) * 10+n div 10) then writeln ('Palindrom') else

    writeln ('No palindrom') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано двузначное число. выяснить является ли оно палиндромом то есть таким числом десятичная запись которого читается слева направо и справа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать на С++. Дано трехзначное число. Выяснить, является ли оно палиндромом ("оборотнем"). Таким числом, десятичная запись которого читается одинаково слева направо и справа налево.
Ответы (1)
Дано натуральное число. Выяснить, является ли оно палиндромом ("перевертышем"), т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. Помогите написать на паскале
Ответы (1)
Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное количество букв надо добавить к входному слову справа, чтобы оно стало палиндромом.
Ответы (1)
Дано трёхзначное число. выясните, является ли оно палиндромом ("перевёртышем"), т. е. таким числом, которое читается одинаково и справа налево, и слева направо.
Ответы (1)
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ответы (1)