Задать вопрос
20 октября, 06:12

Цикл с параметром. Pascale. Нужно написать программу.

Определить количество чисел, кратных 5, среди N чисел, заданных случайным образом в диапозоне от - 50 до 50.

+1
Ответы (1)
  1. 20 октября, 08:20
    0
    Const nmax = 30;

    var a:array [1 ... nmax] of integer;

    i, k, n:integer;

    begin

    randomize;

    k:=0;

    repeat

    write ('N = ') ;

    readln (n) ;

    until n in [1 ... nmax];

    for i:=1 to n do

    begin

    a[i]:=random (101) - 50;

    writeln (a[i]) ;

    if a[i] mod 5 = 0 then inc (k) ;

    end;

    writeln ('Kol-vo: ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Цикл с параметром. Pascale. Нужно написать программу. Определить количество чисел, кратных 5, среди N чисел, заданных случайным образом в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найти все числа в диапозоне от 20 до 450, кратных 4. Подсчитать все числа. применить цикл с параметром
Ответы (1)
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)
Помогите решить задачи на цикл с параметром. Решения оформить как в Паскале. 1) задать 5 чисел. найти среднюю сумму положительных чисел, произведение чисел, некратных 12 и количество четных чисел среди заданных 2) В фирме работают 5 сотрудников.
Ответы (1)