Задать вопрос
25 сентября, 14:24

составить блок-схему, которая по заданному с клавиатур порядковому номеру N кол-во числео выясняет N число фибиначчи. Например 1,1, 2,3,5,8,12,21 т. е. 1+1=2, 2+1=3,3+2=5, 5+8=12 и. т. д

+2
Ответы (1)
  1. 25 сентября, 15:53
    0
    var N, m, m1, m2, i:integer;

    begin

    read (N) ;

    m1:=1;

    m2:=0;

    for i:=2 to N do begin

    m:=m1+m2;

    m2:=m1;

    m1:=m;

    end;

    write (m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить блок-схему, которая по заданному с клавиатур порядковому номеру N кол-во числео выясняет N число фибиначчи. Например 1,1, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1). Дано целое число Х. Составьте программу которая выясняет верно ли что 0 больше или равно Х и больше 1. 2). Дано целое число П. Составьте программу которая выясняет является им значение П кратное 3.
Ответы (1)
написать программу: по заданному порядковому номеру дня недели напечатать его название и указать рабочий это день или не рабочий
Ответы (2)
Y={0, если х≤0 х, если 0
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
Написать программу в Паскаль: 1) Составьте программу, которая по заданному году и номеру месяца определит кол-во дней в этом месяце. 2) Для любого 2-ух значного числа, вывести его значение в словесной форме.
Ответы (1)