Задать вопрос
11 февраля, 16:59

определить сумму трех цифр пятизначного числа

+2
Ответы (1)
  1. 11 февраля, 20:28
    0
    Программа считает сумму последних трех цифр:

    Pascal:

    var n:longint;

    sum, i:integer;

    begin

    repeat

    write ('N = ') ;

    readln (n) :

    until (n>=10000) and (n<=99999) ;

    sum:=0;

    for i:=1 to 3 do

    begin

    sum:=sum + (n mod 10) ;

    n:=n div 10;

    end;

    writeln ('Summa: ', sum) ;

    end.

    C++:

    #include

    using namespace std;

    int main ()

    {

    int n, sum = 0;

    do

    {

    cout <<"N = ";

    cin >>n;

    }

    while (n99999) ;

    for (int I = 1; I<=3; I++)

    {

    sum+=n%10;

    n/=10;

    }

    cout <<"Summa: " <
    return 0;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «определить сумму трех цифр пятизначного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Информатика 8 класс 1) вывести трехзначные числа сумма цифр которых простое число 2) Определить сумму цифр трехзначного числа 3) определить являеться ли четным число введенное с клавиатуры 4) определить НОК (наименьшее обшее кратноечисло без
Ответы (1)