Задать вопрос
1 ноября, 15:29

Упорядочить одномерный числовой массив по возрастанию (Pascal)

+2
Ответы (1)
  1. 1 ноября, 16:20
    0
    uses crt;

    const n = 10;

    var a : array [ 1 ... n ] of integer;

    i, j, k : byte; c : integer;

    begin

    randomize;

    clrscr;

    writeln ('исходный массив: ') ;

    for i : = 1 to n do begin

    a [ i ] : = random (19) - 9;

    write (a [ i ] : 3) ; end; writeln;

    k : = 0; for i : = 1 to n - 1 do f

    or j:=i+1 to n do if a[i]>a[j] then begin

    c:=a[i];

    a[i]:=a[j];

    a[j]:=c;

    inc (k) ;

    end;

    writeln ('результат сортировки: ') ;

    for i:=1 to n do write (a[i]:3) ;

    writeln;

    writeln ('кол-во перестановок = ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Упорядочить одномерный числовой массив по возрастанию (Pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Что такое одномерный массив в информатике? Для чего используется одномерный массив? Как описывается одномерный массив?
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)