Задать вопрос
27 июня, 06:38

составьте программу вычисления корней квадратного уравнения aх^2+вх+с=0 по данным значениям его коэффициентов.

+3
Ответы (1)
  1. 27 июня, 07:09
    0
    Var a, b, c, d, x1, x2 : real; / / задание переменных действительных чисел.

    begin

    write ('a = ') ; readln (a) ; / / запрос у пользователя первого коэффициента

    write ('b = ') ; readln (b) ; / / запрос у пользователя второго коэффициента

    write ('c = ') ; readln (c) ; / / запрос у пользователя третьего коэффициента

    d : = b*b - 4*a*c; / / расчет дискриминанта

    if d=0 then / / ветка для решения при нулевом дискриминанте

    begin

    x1 : = b / (2 * a)

    writeln (x1:3:3) ;

    end / / окончание при нулевом дискриминанте

    else

    if d>0 then / / ветка для решения при положительном дискриминанте

    begin

    x1 : = (- b + sqrt (d) / (2 * a) ; / / первый корень

    x2 : = (- b - sqrt (d) / (2 * a) ; / / второй корень

    writeln (x1:3:3, ' ', x2:3:3) ; / / вывод ответа

    end

    else / / ветка решения для отрицательного дискриминанта

    writeln ('Нет действительных корней') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составьте программу вычисления корней квадратного уравнения aх^2+вх+с=0 по данным значениям его коэффициентов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу вычисления корней квадратного уравнения по данным значениям его коэффициентов
Ответы (1)
Создайте программу вычисления корней квадратного уравнения по данным значениям его коэффициентов
Ответы (1)
1. Составьте программу сортировки по возрастанию знаачений трех переменных: А Б С 2. Составьте программу вычисления корней квадратонго уравнения по данным знаечениям его коэффициентов
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)