Задать вопрос
10 сентября, 22:24

Составить программу вычисления корней квадратного уравнения по данным значениям его коэффициентов

+3
Ответы (1)
  1. 11 сентября, 01:24
    0
    Var

    a, b, c, d:real;

    begin

    writeln ('a, b, c?') ;

    readln (a, b, c) ;

    d:=sqr (b) - 4*a*c;

    if d<0 then writeln ('d<0') ;

    if d>0 then

    writeln ('x1 = ', ((-b) + sqrt (d)) / (2*a),' x2 = ', ((-b) - sqrt (d)) / (2*a)) ;

    if d=0 then

    writeln ('x1 = ', (-b) / (2*a)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления корней квадратного уравнения по данным значениям его коэффициентов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике