Задать вопрос
26 марта, 11:54

составить программу записывающее четырехзначное число наоборот

+2
Ответы (1)
  1. 26 марта, 12:42
    0
    var a, x, b, y, z, c, r, m:integer;

    begin

    write ('a=') ;

    readln (a) ;

    r:=a div 1000;

    m:=a mod 1000;

    x:=m div 100;

    b: = m mod 100;

    y:=b div 10;

    z:=b mod 10;

    c: = z*1000+y*100+x*10+r;

    writeln ('c=', c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу записывающее четырехзначное число наоборот ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Составьте программу проверяющая является ли данное целое число четырехзначным числом. На экране должно быть сообщение число четырехзначное или число не четырехзначное. По паскалю.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Дано четырехзначное число n. Выписать число в обратном порядке. n - четырехзначное число (1762) - исходные данные a, b, c, d - цифры этого числа (вспомогательные переменные). m - обратное число (результат) Решить через div и mod
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)