Задать вопрос
19 февраля, 06:08

Составить алгоритм решения задачи с помощью алгоритмического языка Pascal и с помощью блок-схем, используя конструкцию алгоритма с ветвлением.

Написать алгоритм решения задачи, которая решает уравнение ax + b = 0 относительно x для любых чисел a и b, введенных с клавиатуры. Все числа считаются действительными.

+2
Ответы (1)
  1. 19 февраля, 09:32
    0
    program qq;

    uses crt;

    var a, x, b:real;

    begin

    crlscr;

    writeln ('введите а и b ') ;

    readn (a, b) ;

    if a=0 then

    if b=0 then writeln ('x любое число')

    else writeln ('решений нет ')

    else begin

    x: = (-b/a) ;

    writeln (x) ;

    end;

    readln

    end.

    сорри за то что все в куче
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм решения задачи с помощью алгоритмического языка Pascal и с помощью блок-схем, используя конструкцию алгоритма с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
требовалось написать программу которая решает уравнение а|x|=b относительно х для любых чисел а и b, введенных с клавиатуры
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Нарисуйте блок-схемы и напишите на АЯ два варианта алгоритма решения задачи: выбрать из двух числовых величин наибольшее значение. Первый вариант с полным ветвлением, второй вариант - с неполным ветвлением.
Ответы (1)