Задать вопрос
6 октября, 03:25

написать программу, каторая выделит все запятые из строки st начиная с позиции р

+3
Ответы (1)
  1. 6 октября, 06:23
    0
    {Программа на Free Pascal}

    Var st:string;

    z, p, i:integer;

    begin

    z:=0;

    readln (st) ; {Считываем строку}

    read (p) ; {Считываем позию}

    for i:=p to length (st) do if (st[i] = ',') then inc (z) ; {Пробегаемся по строке с позиции p и ищем,}

    writeln (z) ; {Выводим кол-во найденых запятых}

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу, каторая выделит все запятые из строки st начиная с позиции р ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Размер окна текстового редактора - 20 строк по 64 символа в строке. Курсор находится в левом верхнем углу экрана и указывает на символ, стоящий в 25 - й строке и 5 - й позиции текста.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Написать программу в Паскале! Указание: Заполнить двумерный числовой массив И (8,8) случайными целыми числами в интервале [-60,60]. Написать единую программу для всех задач, ответ каждой задачи выводить с новой строки.
Ответы (1)