Задать вопрос
28 августа, 12:24

Даны целые числа x, y, z. Найти максимальное из (x-y, x/y, z*x). x=2,

y=0.3, z=0.5. (Паскаль)

Буду признательна за ответ.

+2
Ответы (2)
  1. 28 августа, 12:33
    0
    решение для данных чисел.

    var x, y, z, a, b, c: real;

    begin

    x:=2;

    y:=0.3;

    z:=0.5;

    a:=x-y;

    b:=x/y;

    c:=z*x;

    write ('naibolshee x/y = ', b:2:1) ;

    readln;

    end.
  2. 28 августа, 14:53
    0
    program z1;

    var

    x, y, z, a, b, c:real;

    begin

    x:=2;

    y:=0.3;

    z:=0.5;

    a:=x-y;

    b:=x/y;

    c:=z*x;

    if a > b

    then begin

    if a < c

    then write ('Наибольшее', c)

    else write ('Наибольшее', a)

    end;

    else write ('Наибольшее', b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны целые числа x, y, z. Найти максимальное из (x-y, x/y, z*x). x=2, y=0.3, z=0.5. (Паскаль) Буду признательна за ответ. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Даны свойства поля в Ворде к ним надо подобрать правильные варианты1) целые числа 0 до 225 2) целые числа от - 32768 до 32767 3) целые числа от - 2147483648 до 2147483647 4) числа от - 1,797*10308 до 1,797*10308 Byte - Long Integer - Double -
Ответы (1)
Числа в языке Pascal различаются: А) как натуральные и целые; Б) как целые и вещественные; В) как натуральные и вещественные; Г) как целые и иррациональные; Д) как целые и рациональные.
Ответы (1)
Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3. Программа получает на выход целые числа.
Ответы (1)