Задать вопрос
27 сентября, 20:47

Дан массив целых чисел, все элементы кратные числу 5, заменить на 0.

+4
Ответы (1)
  1. 27 сентября, 23:24
    0
    const max = 99;

    var a:array[0 ... max] of integer;

    var i:integer;

    begin

    randomize;

    for i:=1 to max do

    a[i]:=random (5001) ;

    for i:=1 to max do begin

    if ((a[i] mod 5) = 0) then a[i]:=0;

    end;

    for i:=1 to max do

    writeln (a[i]) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив целых чисел, все элементы кратные числу 5, заменить на 0. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Дан массив целых чисел из 12 элементов. Напечатать все четные элементы. 2) Дан массив целых чисел из 10 элементов. Все элементы, кратные числу 10, заменить нулём. Нужна полная программа, Pascal ABC.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
1. Дан массив целых чисел. Все отрицательные элементы заменить положительными. 2. Дан массив целых чисел. Чётные элементы возвести в квадрат остальные разделить пополам
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)