Задать вопрос
3 июля, 15:40

напишите программу которая производит обмен значений переменных х и у если х больше у

+5
Ответы (1)
  1. 3 июля, 18:39
    0
    Если не использовать дополнительных переменных (для чисел), то:

    Var x, y:integer;

    begin

    read (x, y) ;

    x:=x+y;

    y:=x-y;

    x:=x-y;

    writeln (x, ' ', y) ;

    end.

    Можно и через дополнительную переменную:

    Var x, y, s:integer;

    begin

    read (x, y) ;

    s:=x;

    x:=y;

    y:=s;

    writeln (x, ' ', y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «напишите программу которая производит обмен значений переменных х и у если х больше у ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задания. 1. Найти простейшую формулу от трёх переменных, принимающую значение 0 только на следующих наборах значений переменных: 7) А (0,0,0) = А (0,1,1) = А (1,0,1) = А (1,1,1) 2.
Ответы (1)
Что осуществляется с помощью этих трех действий: a=a+b b=a-b a=a-b a) нахождение суммы и разности двух переменных б) нахождение среднеарифметического двух переменных в) обмен значениями двух переменных г) нахождение максимального значения двух
Ответы (1)
Даны величины переменных A, B, C, D. Требуется перенести значения переменных, следующим образом: в D сумму значений переменных С и В, в переменную А поместить значение из В, в В значение из С, в С значение из D решение в паскале
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)