Задать вопрос
17 апреля, 04:27

Вычислить на паскале: p = (xt) !; n!=1*2 * ... * n; t=1,5? если x-чётное t=2, если х-нечётное

+2
Ответы (1)
  1. 17 апреля, 07:37
    0
    var

    x, i, p:integer;

    begin

    write ('x = ') ; readln (x) ;

    if x mod 2 = 0 then

    x : = trunc (x * 1.5)

    else

    x : = x * 2;

    p : = 1;

    for i : = 2 to x do

    p : = p * i;

    writeln ('p = ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить на паскале: p = (xt) !; n!=1*2 * ... * n; t=1,5? если x-чётное t=2, если х-нечётное ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать в паскале! Ввести три целых числа x, y, z. Если хотя бы одно из них четное, то первому четному числу присвоить значение произведения этих чисел.
Ответы (1)
Составить программу в паскале Ввести число. Если оно четное и положительное, разделить его на 4, если четное и отрицательное - умножить на 5, если нечетное - возвести в квадрат.
Ответы (1)
Написать программу в паскале: определить, четное число или нечетное, если четное - разделить на два и вывести результат на экран
Ответы (1)
даны числа 400, 121, 93,80, 4. прочитай правила и запиши на каждом листке. если число нечётное то его записывают на листке с подписью дик если число нечётное и трехзначное то его записывают на листке с подписью ник если число четное или трехзначное
Ответы (1)
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)