Задать вопрос
19 июля, 22:00

Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое

+1
Ответы (2)
  1. 20 июля, 01:08
    0
    const

    n = 10;

    var

    a, summ, i:integer;

    begin

    randomize;

    summ : = 0;

    for i : = 1 to n do

    begin

    a : = random (20) + 1;

    summ : = summ + a;

    write (a, ' ') ;

    end;

    writeln;

    writeln ('Среднее арифметическое этих чисел ', summ / n) ;

    end.
  2. 20 июля, 01:15
    0
    program random_1;

    var

    x, sum, i:integer;

    begin

    randomize;

    writeln ('Ряд случайных чисел: ') ;

    for i:=1 to 10 do begin

    x:=random (20) + 1;

    sum:=sum+x;

    if i10 then write (x,', ')

    else writeln (x,'.') ;

    end;

    writeln ('Среднее арифметическое этих чисел ', sum/10) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на языке паскаль, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Составить программу, которая генерирует 10 случайных чисел в диапазоне от - 20 до 30, выводит эти числа на экран и вычисляет сумму отрицательных
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Написать программу, которая генерирует и выводит на экран массив с с 10 случайных чисел в диапазоне от - 100 до 100, и выводит сумму четных чисел (в Visual Studio)
Ответы (1)