Задать вопрос
13 июня, 14:45

Составить программу, которая генерирует 10 случайных чисел в диапазоне от - 20 до 30, выводит эти числа на экран и вычисляет сумму отрицательных

+2
Ответы (1)
  1. 13 июня, 17:03
    0
    Var a:array[1 ... 10] of integer;

    i, s:integer;

    begin

    randomize;

    for i:=1 to 10 do begin

    a[i]:=random (51) - 20; write (a[i],' ') ; end;

    writeln;

    s:=0;

    for i:=1 to 10 do

    if a[i]<0 then s: = s+a[i];

    writeln ('Сумма отрицательных чисел равна ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая генерирует 10 случайных чисел в диапазоне от - 20 до 30, выводит эти числа на экран и вычисляет сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое
Ответы (2)
Напишите программу на языке паскаль, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое.
Ответы (1)
Написать программу, которая генерирует и выводит на экран массив с с 10 случайных чисел в диапазоне от - 100 до 100, и выводит сумму четных чисел (в Visual Studio)
Ответы (1)