Задать вопрос
20 ноября, 11:32

Выводятся 14 чисел определить сколько среди них положительных включая 0 и солько отрицательных числавводятся в одну переменную в цикле

+1
Ответы (1)
  1. 20 ноября, 13:07
    0
    Program Stats;

    var a, k, d, c:integer;

    begin

    d:=0;

    k:=0;

    c:=0;

    repeat

    readln (a) ;

    d:=d+1;

    if a> = 0

    then

    begin

    k:=k+1;

    end;

    if a<0

    then

    begin

    c:=c+1;

    end;

    until d = 14;

    writeln (' + ', k) ;

    writeln (' - ', c) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Выводятся 14 чисел определить сколько среди них положительных включая 0 и солько отрицательных числавводятся в одну переменную в цикле ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программу с оператором while вводятся 5 чисел. определить, сколько среди них положительных (включая 0) и сколько отрицательных. (числа вводятся в одну переменную в цикле).
Ответы (1)
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)
Напишите программу на Паскале. Дан массив положительных и отрицательных чисел. Вычислить сумму положительных и произведение отрицательных чисел. А[1 ... 10]
Ответы (1)
Программа которая будет складывать переменную а с числом 3. при этом пока сумма будет меньше чем 25 требуется увеличить переменную а на одну еденицу в каждом цикле
Ответы (1)