Задать вопрос
26 апреля, 03:56

Поменяйте между собой значения двух переменных X, Y, не используя дополнительной переменной.

+5
Ответы (1)
  1. 26 апреля, 06:20
    0
    var

    x, y:real;

    begin

    readln (x) ;

    readln (y) ;

    x:=x+y;

    y:=x-y;

    x:=x-y;

    writeln (x,' ', y)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Поменяйте между собой значения двух переменных X, Y, не используя дополнительной переменной. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Запишите на алгоритмическом языке алгоритм, в результате которого переменной A будет присвоено значение переменной B, переменной B-значение переменной C, а переменной C-значение переменной A. Используйте не более одной промежуточной переменной.
Ответы (1)
Что осуществляется с помощью этих трех действий: a=a+b b=a-b a=a-b a) нахождение суммы и разности двух переменных б) нахождение среднеарифметического двух переменных в) обмен значениями двух переменных г) нахождение максимального значения двух
Ответы (1)
Сколько промежуточных переменных потребуется для того, чтобы переменной А было присвоено значение В, переменной В - значение переменной С, а переменной С - значение переменной А? Запишите соответствующий алгоритм на алгоритмическом языке.
Ответы (1)
Python Известны значения двух переменных, содержащие числа. Напишите программу, меняющую значения этих переменных между собой без использования третьей, буферной переменной.
Ответы (1)
Задача1 Введите числа в переменные a, b и c и напишите программу, которая меняет местами значения переменных по следующей схеме, чтобы в переменной а оказалось первоначальное значение переменной с, в переменной b - значение а, в переменной с -
Ответы (1)