Задать вопрос
29 октября, 21:41

с клавиатуры вводится строка состоящая из букв, знака пробела и циифр. определите количество цифр в этой строке

+2
Ответы (1)
  1. 30 октября, 01:37
    0
    var

    s : string;

    i, c : integer;

    begin

    readln (s) ;

    c : = 0;

    for i : = 1 to length (s) do

    if (ord (s[i]) > 47) and (ord (s[i] < 58) then inc (c) ;

    writeln (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «с клавиатуры вводится строка состоящая из букв, знака пробела и циифр. определите количество цифр в этой строке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Паскаль 1) Задана строка, проверить есть ли в этой строке буква "а" 2) задана строка, проверить сколько раз встречаться в этой строке буква "м" 3) задана строка, удалить из этой строки все буквы "и"
Ответы (1)
С клавиатуры вводится строка со словами, разделёнными пробелами (к примеру "йогурт банан ананас"). Необходимо отстортировать слова в этой строке по алфавиту (чтобы конечная строка получилась "ананас банан йогурт").
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)