Задать вопрос
5 июля, 13:01

Программа 12. Написать программу, которая бы по номеру дня недели (целому числу от 1 до 7) выдавала бы количество уроков в вашей группе (или сообщение "выходной").

Программа 13. Пользователь вводит действительное число. Требуется определить: 1. положительное это число или отрицательное; 2. целое это число или нецелое; 3. четное это число или нечетное; Выбор варианта определяется пользователем.

+4
Ответы (1)
  1. 5 июля, 15:22
    0
    12) var A: array[1 ... 7] of integer;

    k: integer;

    begin

    randomize;

    for k : = 1 to 7 do

    A[k] : = random (5) ;

    write ("vvedite den' nedeli: ") ;

    readln (k) ;

    if (k 7) writeln ("error") ;

    else if (A[k] 0) then writeln ("segodnya urokov: ", A[k]) ;

    else write ("vyhodnoy") ;

    end.

    13) var k: real;

    begin

    write ("vvedite chislo: ") ;

    readln (k) ;

    if (k > 0) then write ("polozhitel'noe, ") ;

    else if (k < 0) then write ("otricatel'noe, ") ;

    else write ("nol', ") ;

    if (k mod 1 0) then write ("neceloe, ") ;

    else write ("celoe, ") ;

    if (k mod 2 0) then writeln ("nechetnoe") ;

    else writeln ("chetnoe") ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа 12. Написать программу, которая бы по номеру дня недели (целому числу от 1 до 7) выдавала бы количество уроков в вашей группе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Паскаль. Составить программу введённого пользователем числа (целое или нет; положительное, отрицательное или нуль; чётное или нечётное)
Ответы (1)
Напишите программу на паскале А. выясните какие числа ввел пользователь: положительное или отрицательное? Б. выясните какие числа ввел пользователь: четное или нечетное?
Ответы (1)
Информатика. 5 Класс. С использованием Оператора выбора. С клавиатуры вводится число - номер дня недели. По номеру дня недели определить и вывести количество уроков в этот день.
Ответы (1)
Написать программу на С++, которая по номеру дня недели (целому числу от 1 до 7) выдаёт в качестве результата количество уроков в вашем классе в этот день. Реализовать программу через функцию
Ответы (1)