Задать вопрос
13 января, 11:08

Найти все натуральные числа а, b и с из интервала от 1 до 20, для которых выполняется равенство: a^2+b^2=c^2 (составить программу на языке программирования)

+4
Ответы (1)
  1. 13 января, 12:03
    0
    var a, b, c:integer;

    begin

    for a: = 1 to 20 do

    for b: = 1 to 20 do

    for c: = 1 to 20 do

    begin

    if a*a+b*b=c*c then

    writeln (a:4, b:4, c:4) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все натуральные числа а, b и с из интервала от 1 до 20, для которых выполняется равенство: a^2+b^2=c^2 (составить программу на языке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Даны три действительных числа: a, b, c. Проверьте, выполняется ли равенство a + b = c. Если равенство выполняется, выведите YES, если не выполняется, выведите NO.
Ответы (1)
Дан интервал чисел [1, n]. Составить программу, которая чётные числа из этого интервала заменит на соответствующие кубы этих чисел, а все нечётные числа из этого интервала - заменит значением - 1.
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
Оператор цикла while ... do отличается от цикла for ... to, тем что 1. выполняется хотя бы один раз 2. выполняется хотя бы один раз 3. может не выполняться ни разу 4. выполняется известное число раз 5. выполняется неизвестное число раз
Ответы (1)