Задать вопрос
12 октября, 08:09

написать программу которая находит сумму четных чисел от 0 до 1000

+4
Ответы (2)
  1. 12 октября, 11:21
    0
    var s, i: integer;

    begin

    s:=0;

    for i:=0 to 1000 do if i mod 2 = 0 then s:=s+i;

    write (s) ;

    end.
  2. 12 октября, 11:24
    0
    Program as;

    Var s: integer;

    begin

    For i:=0 to 1000 do

    If i mod 2=0 then s:=s+i; {Если число делится на 2 без остатка плюсуем его к общей сумме}

    Writeln (s) ;

    readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу которая находит сумму четных чисел от 0 до 1000 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Написать программу, которая выведет 4 первые четных числа (2,4,6,8) и написать программу которая находит сумму этих чисел.
Ответы (1)
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)