Задать вопрос
30 июня, 03:54

Вводится натуральное число: если это число четырехзначное то выяснить является ли последовательность цифр от старшего к младшему арифметич последовательностью; если нет то увеличить число в 2 раза

+5
Ответы (1)
  1. 30 июня, 05:58
    0
    var n:integer;

    a, b, c, d:integer; x, y, z:real;

    begin

    read (n) ;

    if n>999 then begin

    a:=n div 1000;

    b:=n mod 1000 div 100;

    c:=n mod 100 div 10;

    d:=n mod 10 div 1;

    x: = (a-b) ;

    y: = (b-c) ;

    z: = (c-d) ;

    if a>b then write (n*2) else if (x=y) and (y=z) then write ('Arif posledovatelnost') ;

    if (xy) and (yz) then write (n*2) ;

    end

    else write ('Chislo ne 4 znachnoe') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводится натуральное число: если это число четырехзначное то выяснить является ли последовательность цифр от старшего к младшему арифметич ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)