Задать вопрос
16 августа, 13:58

1. дано слово. удвоить в нем все буквы, стоящие на четных местах

2. составьте программу, определяющую, на какую букву заканчивается второе слово в предложении

+5
Ответы (1)
  1. 16 августа, 15:01
    0
    for i : = 1 to length (s) do

    begin

    res : = res + s[i];

    if i mod 2 = 0 then

    res : = res + s[i];

    end;

    writeln (res) ;

    i : = Pos (" ", s) ; {ищем первый пробел}

    Delete (s; i; 1) ; {удаляем первый пробел}

    i : = Pos (" ", s) ; {ищем второй пробел, котрый теперь первый}

    writeln (s[i-1]) ; {выдаем знак который находится перед пробелом}
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. дано слово. удвоить в нем все буквы, стоящие на четных местах 2. составьте программу, определяющую, на какую букву заканчивается второе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы