Задать вопрос
14 ноября, 23:49

3. Задан ряд последовательных натуральных чисел от n до m (n


местах, затем из оставшегося ряда удаляют все числа стоящие на нечетных местах.

Эти действия повторяют до тех пор пока не останется одно число, Определить это

число.

Пример:

nchet. in

post. out

5

10

8

+5
Ответы (1)
  1. 15 ноября, 00:45
    0
    uses crt;

    var n, m, i, j, k:integer;

    a:array[1 ... 1000] of integer;

    begin

    repeat

    writeln ('Введите 2 натуральнвх числа n
    read (n, m) ;

    until

    (n>0) and (n
    writeln ('Начальный ряд:') ;

    k:=0;

    for i:=n to m do

    begin

    inc (k) ; a[k]:=i;

    write (a[i]:4) ;

    end;

    writeln;

    while k>=2 do

    begin

    i:=1;

    while i<=k do

    begin for j:=i to k-1 do

    a[j]:=a[j+1];

    k:=k-1;

    i:=i+1;

    end;

    i:=2;

    while i<=k do

    begin f

    or j:=i to k-1 do

    a[j]:=a[j+1];

    k:=k-1;

    i:=i+1;

    end;

    end;

    write (a[k]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «3. Задан ряд последовательных натуральных чисел от n до m (n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1 вариант. 1. Найти сумму и произведение первых 6 последовательных натуральных чисел. 2. Найти сумму первых k последовательных нечетных чисел. 3. Вывести на экран натуральные нечётные числа от 5 до 55. 4.
Ответы (1)
1) Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2) Задан массив из 11 целых чисел. Посчитать количество нечётных элементов массива. 3) задан массив из 9 целых чисел. Вывести на экран чётные элементы
Ответы (1)
1) найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2) вывести на экран натуральные нечетные числа от 5 до 55. тоже паскаль 3) найти произведение последовательных натуральных чисел от n до m.
Ответы (1)
Задан ряд последовательных натуральных чисел от n до m (n
Ответы (1)
1. Задан полный путь к файлу C:/Мои документы/доклад. txt Каково полное имя файла? а) C: / Мои документы/доклад. txt б) Мои документы/доклад. txt в) доклад г) доклад. txt 2. Задан полный путь к файлу C:/Мои документы/доклад.
Ответы (2)