Задать вопрос
24 марта, 20:55

Напишите на ^ Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива.

+1
Ответы (2)
  1. 24 марта, 21:37
    0
    Program Sred;

    var

    n, i, sum : integer;

    mas: array[1 ... 20] of integer;

    af: real;

    begin

    sum : = 0;

    n : = 20;

    writeln ('введите элементы массива') ;

    for i:=1 to n do

    begin

    readln (mas[i]) ;

    sum : = sum + mas[i];

    end;

    af : = sum/n;

    writeln (af) ;

    end.
  2. 24 марта, 22:19
    0
    орфографию проверь

    var N, i, z, l:integer;

    a:array[1 ... 100] of integer;

    for i:=1 to N do

    begin

    readln (a[i]) ;

    l:=l+a[i];

    end;

    z:=l/N;

    writeln (z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите на ^ Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Тема массив. Напишите на Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)