Задать вопрос
12 августа, 22:19

Составить программу вычисления сумму четных чисел от 2 до n

+5
Ответы (2)
  1. 12 августа, 22:26
    0
    program s;

    uses crt;

    var n, i, sum:integer;

    begin

    clrscr;

    write ('n=') ;

    readln (n) ;

    s:=0;

    for i:=2 to n do

    begin

    if not odd (i) then

    s:=s+i;

    end;

    writeln (s) ;

    readln;

    end.
  2. 12 августа, 22:36
    0
    Program Summa

    Uses Crt;

    var i, n, s:longint;

    begin

    clrscr;

    write ('Введите n: ') ;

    readln (n) ;

    s:=0;

    for i:=2 to n do

    if (i mod 2) = 0 then s:=s+i;

    writeln ('Сумма всех чётных от 2 до n: ', s) ;

    readkey

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления сумму четных чисел от 2 до n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)